follow me icons

Friday, January 30, 2015

Gem::InstallError: i18n requires Ruby version >= 1.9.3 Heroku

While doing a gem push heroku, I encountered the following error:

Installing dependencies using 1.7.12
       Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
       Fetching gem metadata from https://rubygems.org/...........
       Gem::InstallError: i18n requires Ruby version >= 1.9.3.
       Installing multi_json 1.10.1
       Installing rake 10.4.2
       An error occurred while installing i18n (0.7.0), and Bundler cannot continue.
       Make sure that `gem install i18n -v '0.7.0'` succeeds before bundling.
       Bundler Output: Fetching gem metadata from https://rubygems.org/...........
       
       Gem::InstallError: i18n requires Ruby version >= 1.9.3.
       Installing multi_json 1.10.1
       Installing rake 10.4.2
       An error occurred while installing i18n (0.7.0), and Bundler cannot continue.

       Make sure that `gem install i18n -v '0.7.0'` succeeds before bundling.


My Ruby version in Heroku is still using Ruby 1.9.2, so to solve this I simply add the following line in my gemfile

source 'https://rubygems.org'ruby '2.0.0'